# vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs

Advisory record · `GHSA-pmqf-x6x8-p7qw`

- **Identifiers:** `GHSA-pmqf-x6x8-p7qw` · `CVE-2025-62372` · `PYSEC-2026-2019`
- **State:** Confirmed
- **Severity:** CVSS 8.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-129](https://cwe.mitre.org/data/definitions/129.html)
- **Tags:** [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 20 Nov 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Nov 2025, 21:23 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vllm` (PyPI): affected `>=0.5.5, <0.11.1`; fixed in `0.11.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> vLLM versions from 0.5.5 before 0.11.1 are vulnerable to a denial of service. An attacker who can send requests to the server can pass multimodal embedding inputs with the correct number of dimensions but a wrong shape, such as an incorrect hidden dimension, crashing the engine. Upgrade to vLLM 0.11.1 or later. As a workaround, restrict access to trusted users with an API key, or set --limit-mm-per-prompt to 0 for non-text modalities, though this leaves the model accepting only text.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.3 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0041, the 35th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:29 UTC: First seen by agentprime
- 31 Oct 2026, 14:29 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-pmqf-x6x8-p7qw)

## Sources

- [GitHub Advisory Database: GHSA-pmqf-x6x8-p7qw](https://github.com/advisories/GHSA-pmqf-x6x8-p7qw)
- [OSV: GHSA-pmqf-x6x8-p7qw](https://osv.dev/vulnerability/GHSA-pmqf-x6x8-p7qw)
- <https://github.com/vllm-project/vllm/security/advisories/GHSA-pmqf-x6x8-p7qw>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-62372>
- <https://github.com/vllm-project/vllm/pull/27204>
- <https://github.com/vllm-project/vllm/pull/6613>
- <https://github.com/vllm-project/vllm/commit/58fab50d82838d5014f4a14d991fdb9352c9c84b>
- <https://github.com/advisories/GHSA-pmqf-x6x8-p7qw>
- <https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-2019.yaml>
- <https://github.com/vllm-project/vllm>
- <https://pypi.org/project/vllm>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-pmqf-x6x8-p7qw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-pmqf-x6x8-p7qw/>. Everything for agents: <https://agentprime.io/llms.txt>.
