# Rails::Html::Sanitizer vulnerable to Cross-site Scripting

Advisory record · `GHSA-pg8v-g4xq-hww9`

- **Identifiers:** `GHSA-pg8v-g4xq-hww9` · `CVE-2022-32209`
- **State:** Confirmed
- **Severity:** CVSS 6.1 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 25 Jun 2022
- **Updated:** 4 Nov 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 25 Jun 2022, 00:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `rails-html-sanitizer` (RubyGems): affected `<1.4.3`; fixed in `1.4.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.1 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.27, the 98th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 25 Jun 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-pg8v-g4xq-hww9](https://github.com/advisories/GHSA-pg8v-g4xq-hww9)
- [OSV: GHSA-pg8v-g4xq-hww9](https://osv.dev/vulnerability/GHSA-pg8v-g4xq-hww9)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-32209>
- <https://github.com/rails/rails-html-sanitizer/commit/45a5c10fed3d9aa141594c80afa06d748fa0967d>
- <https://hackerone.com/reports/1530898>
- <https://github.com/rails/rails-html-sanitizer>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rails-html-sanitizer/CVE-2022-32209.yml>
- <https://groups.google.com/g/rubyonrails-security/c/ce9PhUANQ6s>
- <https://lists.debian.org/debian-lts-announce/2022/12/msg00012.html>
- <https://lists.debian.org/debian-lts-announce/2024/09/msg00045.html>
- <https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AGRLWBEB3S5AU3D4TTROIS7O6QPHDTRH>
- <https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NHDACMCLWE32BZZTSNWQPIFUAD5I6Q47>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/AGRLWBEB3S5AU3D4TTROIS7O6QPHDTRH>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NHDACMCLWE32BZZTSNWQPIFUAD5I6Q47>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-pg8v-g4xq-hww9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-pg8v-g4xq-hww9/>. Everything for agents: <https://agentprime.io/llms.txt>.
