# Invalid char to bool conversion when printing a tensor

Advisory record · `GHSA-pf36-r9c6-h97j`

- **Identifiers:** `GHSA-pf36-r9c6-h97j` · `BIT-tensorflow-2022-41911` · `CVE-2022-41911` · `PYSEC-2026-1954` · `PYSEC-2026-3222` · `PYSEC-2026-939`
- **State:** Confirmed
- **Severity:** CVSS 4.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-704](https://cwe.mitre.org/data/definitions/704.html)
- **Tags:** [CWE-704](https://agentprime.io/advisories/tag/cwe-704.md)
- **Published:** 21 Nov 2022
- **Updated:** 13 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Nov 2022, 22:18 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `tensorflow` (PyPI): affected `<2.8.4 || >=2.9.0, <2.9.3 || >=2.10.0, <2.10.1`; fixed in `2.8.4`, `2.9.3`, `2.10.1`
- `tensorflow-cpu` (PyPI): affected `>=2.9.0, <2.9.3 || <2.8.4 || >=2.10.0, <2.10.1`; fixed in `2.9.3`, `2.8.4`, `2.10.1`
- `tensorflow-gpu` (PyPI): affected `>=2.10.0, <2.10.1 || <2.8.4 || >=2.9.0, <2.9.3`; fixed in `2.10.1`, `2.8.4`, `2.9.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0044, the 38th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:01 UTC: First seen by agentprime
- 31 Oct 2026, 15:01 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-pf36-r9c6-h97j)

## Sources

- [GitHub Advisory Database: GHSA-pf36-r9c6-h97j](https://github.com/advisories/GHSA-pf36-r9c6-h97j)
- [OSV: GHSA-pf36-r9c6-h97j](https://osv.dev/vulnerability/GHSA-pf36-r9c6-h97j)
- <https://github.com/tensorflow/tensorflow/security/advisories/GHSA-pf36-r9c6-h97j>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-41911>
- <https://github.com/tensorflow/tensorflow/commit/1be743703279782a357adbf9b77dcb994fe8b508>
- <https://github.com/tensorflow/tensorflow>
- <https://github.com/tensorflow/tensorflow/blob/807cae8a807960fd7ac2313cde73a11fc15e7942/tensorflow/core/framework/tensor.cc#L1200-L1227>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-pf36-r9c6-h97j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-pf36-r9c6-h97j/>. Everything for agents: <https://agentprime.io/llms.txt>.
