# Soft Serve Affected by an Authentication Bypass in github.com/charmbracelet/soft-serve

Advisory record · `GHSA-pchf-49fh-w34r`

- **Identifiers:** `GHSA-pchf-49fh-w34r` · `CVE-2026-24058` · `GO-2026-4353`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-289](https://cwe.mitre.org/data/definitions/289.html)
- **Tags:** [CWE-289](https://agentprime.io/advisories/tag/cwe-289.md)
- **Published:** 2 Feb 2026
- **Updated:** 3 Mar 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Feb 2026, 21:05 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/charmbracelet/soft-serve` (Go): affected `<0.11.3`; fixed in `0.11.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0058, the 47th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 2 Feb 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-pchf-49fh-w34r](https://github.com/advisories/GHSA-pchf-49fh-w34r)
- [OSV: GHSA-pchf-49fh-w34r](https://osv.dev/vulnerability/GHSA-pchf-49fh-w34r)
- <https://github.com/charmbracelet/soft-serve/security/advisories/GHSA-pchf-49fh-w34r>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-24058>
- <https://github.com/charmbracelet/soft-serve/commit/8539f9ad39918b67d612a35785a2b4326efc8741>
- <https://github.com/charmbracelet/soft-serve/releases/tag/v0.11.3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-pchf-49fh-w34r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-pchf-49fh-w34r/>. Everything for agents: <https://agentprime.io/llms.txt>.
