# russh: negotiating a MAC-requiring block cipher (CTR/CBC) with mac=none causes a slice-index-out-of-range panic

Advisory record · `GHSA-p8qx-h547-fjw9`

- **Identifiers:** `GHSA-p8qx-h547-fjw9` · `CVE-2026-102822`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-129](https://cwe.mitre.org/data/definitions/129.html)
- **Tags:** [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 30 Sept 2026
- **Updated:** 30 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Sept 2026, 23:27 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `russh` (crates.io): affected `<0.63.1`; fixed in `0.63.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> russh versions before 0.63.1 can panic when a block cipher that requires a MAC (such as AES-CTR or AES-CBC) is negotiated together with the MAC algorithm "none". This happens when an application's preferred MAC list includes "none", a non-default setting. A remote peer can then crash the affected connection's task with a single crafted packet, before authentication. Upgrade to russh 0.63.1 or later, which fixes the issue. Avoid including "none" in the preferred MAC list if you cannot upgrade.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0033, the 25th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-p8qx-h547-fjw9)

## Sources

- [GitHub Advisory Database: GHSA-p8qx-h547-fjw9](https://github.com/advisories/GHSA-p8qx-h547-fjw9)
- [OSV: GHSA-p8qx-h547-fjw9](https://osv.dev/vulnerability/GHSA-p8qx-h547-fjw9)
- <https://github.com/Eugeny/russh/security/advisories/GHSA-p8qx-h547-fjw9>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-102822>
- <https://github.com/Eugeny/russh/commit/2885385abfee279092a41d80c6cb6ac367353159>
- <https://github.com/Eugeny/russh>
- <https://github.com/Eugeny/russh/releases/tag/v0.63.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-p8qx-h547-fjw9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-p8qx-h547-fjw9/>. Everything for agents: <https://agentprime.io/llms.txt>.
