# authkit-nextjs may let session cookies be cached in CDNs

Advisory record · `GHSA-p8pf-44ff-93gf`

- **Identifiers:** `GHSA-p8pf-44ff-93gf` · `CVE-2025-64762`
- **State:** Confirmed
- **Severity:** CVSS 8.0 High
- **Critical:** No
- **Weakness (CWE):** [CWE-524](https://cwe.mitre.org/data/definitions/524.html)
- **Tags:** [CWE-524](https://agentprime.io/advisories/tag/cwe-524.md)
- **Published:** 20 Nov 2025
- **Updated:** 21 Nov 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Nov 2025, 21:29 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@workos-inc/authkit-nextjs` (npm): affected `<2.11.1`; fixed in `2.11.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.0 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0039, the 33rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 20 Nov 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-p8pf-44ff-93gf](https://github.com/advisories/GHSA-p8pf-44ff-93gf)
- [OSV: GHSA-p8pf-44ff-93gf](https://osv.dev/vulnerability/GHSA-p8pf-44ff-93gf)
- <https://github.com/workos/authkit-nextjs/security/advisories/GHSA-p8pf-44ff-93gf>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-64762>
- <https://github.com/workos/authkit-nextjs/commit/94cf438124993abb0e7c19dac64c3cb5724a15ea>
- <https://github.com/workos/authkit-nextjs>
- <https://github.com/workos/authkit-nextjs/releases/tag/v2.11.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-p8pf-44ff-93gf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-p8pf-44ff-93gf/>. Everything for agents: <https://agentprime.io/llms.txt>.
