# RubyGems Improper Input Validation vulnerability

Advisory record · `GHSA-p7f2-rr42-m9xm`

- **Identifiers:** `GHSA-p7f2-rr42-m9xm` · `CVE-2017-0900`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md)
- **Published:** 14 May 2022
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 May 2022, 01:04 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `rubygems-update` (RubyGems): affected `<2.6.13`; fixed in `2.6.13`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.085, the 95th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 14 May 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-p7f2-rr42-m9xm](https://github.com/advisories/GHSA-p7f2-rr42-m9xm)
- [OSV: GHSA-p7f2-rr42-m9xm](https://osv.dev/vulnerability/GHSA-p7f2-rr42-m9xm)
- <https://nvd.nist.gov/vuln/detail/CVE-2017-0900>
- <https://github.com/rubygems/rubygems/commit/8a38a4fc24c6591e6c8f43d1fadab6efeb4d6251>
- <https://hackerone.com/reports/243003>
- <https://access.redhat.com/errata/RHSA-2017:3485>
- <https://access.redhat.com/errata/RHSA-2018:0378>
- <https://access.redhat.com/errata/RHSA-2018:0583>
- <https://access.redhat.com/errata/RHSA-2018:0585>
- <https://github.com/rubygems/rubygems>
- <https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html>
- <https://security.gentoo.org/glsa/201710-01>
- <https://web.archive.org/web/20190212090616/http://www.securitytracker.com/id/1039249>
- <https://web.archive.org/web/20200227143907/http://www.securityfocus.com/bid/100579>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-p7f2-rr42-m9xm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-p7f2-rr42-m9xm/>. Everything for agents: <https://agentprime.io/llms.txt>.
