# rclone local: crafted Range request against a translated symlink panics (DoS)

Advisory record · `GHSA-p6m2-r3w9-mpxw`

- **Identifiers:** `GHSA-p6m2-r3w9-mpxw` · `BIT-rclone-2026-88015` · `CVE-2026-88015` · `GO-2026-6461`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-190](https://cwe.mitre.org/data/definitions/190.html) · [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 10 Sept 2026
- **Updated:** 19 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Sept 2026, 22:49 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/rclone/rclone` (Go): affected `<1.75.1`; fixed in `1.75.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-p6m2-r3w9-mpxw affects the Go module github.com/rclone/rclone before 1.75.1. When rclone's local backend runs with symlink support enabled (--links or links=true), a remote client sending a crafted HTTP Range request for a symlink object can make the request handler panic. An unauthenticated attacker needs only network access to a served symlink, and the panic fails that single request. Upgrade to 1.75.1 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0036, the 29th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:13 UTC: First seen by agentprime
- 31 Oct 2026, 14:13 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-p6m2-r3w9-mpxw)

## Sources

- [GitHub Advisory Database: GHSA-p6m2-r3w9-mpxw](https://github.com/advisories/GHSA-p6m2-r3w9-mpxw)
- [OSV: GHSA-p6m2-r3w9-mpxw](https://osv.dev/vulnerability/GHSA-p6m2-r3w9-mpxw)
- <https://github.com/rclone/rclone/security/advisories/GHSA-p6m2-r3w9-mpxw>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-88015>
- <https://github.com/rclone/rclone/commit/28bf49d66f94acc3f4f7f318504a706686281af9>
- <https://github.com/rclone/rclone>
- <https://github.com/rclone/rclone/releases/tag/v1.75.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-p6m2-r3w9-mpxw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-p6m2-r3w9-mpxw/>. Everything for agents: <https://agentprime.io/llms.txt>.
