# OpenBao's Token Store Allows Cross-Namespace Renewal, Revocation

Advisory record · `GHSA-p49j-v9wc-wg57`

- **Identifiers:** `GHSA-p49j-v9wc-wg57` · `BIT-openbao-2026-40264` · `CVE-2026-40264` · `GO-2026-5526`
- **State:** Confirmed
- **Severity:** CVSS 2.0 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-1259](https://cwe.mitre.org/data/definitions/1259.html)
- **Tags:** [CWE-1259](https://agentprime.io/advisories/tag/cwe-1259.md)
- **Published:** 21 Apr 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Apr 2026, 18:27 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/openbao/openbao` (Go): affected `<0.0.0-20260420162526-f58111d2ca54`; fixed in `0.0.0-20260420162526-f58111d2ca54`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of github.com/openbao/openbao before 0.0.0-20260420162526-f58111d2ca54 let a privileged administrator in one namespace renew or revoke tokens belonging to another namespace when that token's accessor has leaked. Upgrade to 0.0.0-20260420162526-f58111d2ca54 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.0 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0030, the 22nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:13 UTC: First seen by agentprime
- 31 Oct 2026, 14:13 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-p49j-v9wc-wg57)

## Sources

- [GitHub Advisory Database: GHSA-p49j-v9wc-wg57](https://github.com/advisories/GHSA-p49j-v9wc-wg57)
- [OSV: GHSA-p49j-v9wc-wg57](https://osv.dev/vulnerability/GHSA-p49j-v9wc-wg57)
- <https://github.com/openbao/openbao/security/advisories/GHSA-p49j-v9wc-wg57>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-40264>
- <https://github.com/openbao/openbao/pull/2934>
- <https://github.com/openbao/openbao/commit/059cc5950303688335d5c8ab9af8e453795d693a>
- <https://github.com/openbao/openbao>
- <https://github.com/openbao/openbao/releases/tag/v2.5.3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-p49j-v9wc-wg57>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-p49j-v9wc-wg57/>. Everything for agents: <https://agentprime.io/llms.txt>.
