# Docker CLI Plugins: Uncontrolled Search Path Element Leads to Local Privilege Escalation on Windows

Advisory record · `GHSA-p436-gjf2-799p`

- **Identifiers:** `GHSA-p436-gjf2-799p` · `BIT-docker-cli-2025-15558` · `CVE-2025-15558` · `GO-2026-4610`
- **State:** Confirmed
- **Severity:** CVSS 7.0 High
- **Critical:** No
- **Weakness (CWE):** [CWE-427](https://cwe.mitre.org/data/definitions/427.html)
- **Tags:** [CWE-427](https://agentprime.io/advisories/tag/cwe-427.md)
- **Published:** 5 Mar 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Mar 2026, 00:10 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/docker/cli` (Go): affected `>=19.03.0, <29.2.0`; fixed in `29.2.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Docker CLI (github.com/docker/cli) versions 19.03.0 through 29.1.x are affected on Windows, where the CLI searches a non-default system-wide plugin directory that a low-privileged user can create. An attacker with local low-privileged access can plant malicious plugin binaries there that run when a victim opens Docker Desktop or uses CLI plugin features, which can lead to privilege escalation if the CLI runs as a privileged user. Upgrade to version 29.2.0 or later, which removes that search path.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.0 High, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/AU:N/R:U`, from CNA (Docker)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0055, the 46th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-p436-gjf2-799p)

## Sources

- [GitHub Advisory Database: GHSA-p436-gjf2-799p](https://github.com/advisories/GHSA-p436-gjf2-799p)
- [OSV: GHSA-p436-gjf2-799p](https://osv.dev/vulnerability/GHSA-p436-gjf2-799p)
- <https://github.com/docker/cli/security/advisories/GHSA-p436-gjf2-799p>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-15558>
- <https://github.com/docker/cli/pull/6713>
- <https://github.com/docker/compose/pull/12300>
- <https://github.com/docker/cli/commit/13759330b1f7e7cb0d67047ea42c5482548ba7fa>
- <https://docs.docker.com/desktop/release-notes>
- <https://github.com/docker/cli>
- <https://www.zerodayinitiative.com/advisories/ZDI-CAN-28304>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-p436-gjf2-799p>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-p436-gjf2-799p/>. Everything for agents: <https://agentprime.io/llms.txt>.
