# Datadog dd-trace-py: IAST instrumentation can lead to application DOS

Advisory record · `GHSA-p3m5-h5v9-vqj6`

- **Identifiers:** `GHSA-p3m5-h5v9-vqj6` · `CVE-2026-116589`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Oct 2026, 15:37 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ddtrace` (PyPI): affected `>=3.13.0, <4.15.5`; fixed in `4.15.5`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The ddtrace PyPI package, versions 3.13.0 up to but not including 4.15.5, contains a flaw in its IAST string-processing instrumentation that can cause the Python application process to terminate. An attacker who can send input that reaches an affected string operation in an application with IAST enabled (which is off by default) can crash the process, causing denial of service. Upgrade to ddtrace 4.15.5. If upgrading is not possible, the source suggests disabling IAST (DD_IAST_ENABLED=false).

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0033, the 25th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 26 Oct 2026, 21:26 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-116589)
- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-p3m5-h5v9-vqj6)

## Sources

- [GitHub Advisory Database: GHSA-p3m5-h5v9-vqj6](https://github.com/advisories/GHSA-p3m5-h5v9-vqj6)
- [OSV: GHSA-p3m5-h5v9-vqj6](https://osv.dev/vulnerability/GHSA-p3m5-h5v9-vqj6)
- <https://github.com/DataDog/dd-trace-py/security/advisories/GHSA-p3m5-h5v9-vqj6>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-116589>
- <https://github.com/DataDog/dd-trace-py/pull/20786>
- <https://github.com/DataDog/dd-trace-py/pull/20823>
- <https://github.com/DataDog/dd-trace-py/commit/69dc19853247434ceab83e0c1c4e279a2eb2a3f7>
- <https://github.com/DataDog/dd-trace-py/commit/ace972489b57dd020ff52b706bb548a354f2dd69>
- <https://github.com/DataDog/dd-trace-py>
- <https://github.com/DataDog/dd-trace-py/releases/tag/v4.15.5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-p3m5-h5v9-vqj6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-p3m5-h5v9-vqj6/>. Everything for agents: <https://agentprime.io/llms.txt>.
