# Nginx UI: Authenticated Remote Code Execution via Backup Restore App Config Overwrite

Advisory record · `GHSA-p393-cf76-4jmr`

- **Identifiers:** `GHSA-p393-cf76-4jmr` · `CVE-2026-107806` · `GO-2026-6741`
- **State:** Confirmed
- **Severity:** CVSS 9.4 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-94](https://cwe.mitre.org/data/definitions/94.html)
- **Tags:** [Code injection](https://agentprime.io/advisories/tag/code-injection.md)
- **Published:** 9 Oct 2026
- **Updated:** 19 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Oct 2026, 20:45 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.4: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `github.com/0xJacky/Nginx-UI` (Go): affected `>=1.9.10-0.20260421071512-7864e378f5cf, <1.9.10-0.20260728074146-a467ed652591`; fixed in `1.9.10-0.20260728074146-a467ed652591`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Nginx UI versions from 1.9.10-0.20260421071512-7864e378f5cf before 1.9.10-0.20260728074146-a467ed652591 (Go module github.com/0xJacky/Nginx-UI) are affected. An authenticated user can upload a forged encrypted backup to the restore endpoint, overwrite the application config, set nginx command settings, and then run arbitrary commands in the nginx-ui runtime. Upgrade to 1.9.10-0.20260728074146-a467ed652591, which is the fixed version. The source gives no workaround.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.4 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0057, the 47th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:11 UTC: First seen by agentprime
- 31 Oct 2026, 14:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-p393-cf76-4jmr)

## Sources

- [GitHub Advisory Database: GHSA-p393-cf76-4jmr](https://github.com/advisories/GHSA-p393-cf76-4jmr)
- [OSV: GHSA-p393-cf76-4jmr](https://osv.dev/vulnerability/GHSA-p393-cf76-4jmr)
- <https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-p393-cf76-4jmr>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-107806>
- <https://github.com/0xJacky/nginx-ui/commit/a467ed652591fc0cd1b466a1ec751b493faef9f7>
- <https://github.com/0xJacky/nginx-ui>
- <https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-p393-cf76-4jmr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-p393-cf76-4jmr/>. Everything for agents: <https://agentprime.io/llms.txt>.
