# Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)

Advisory record · `GHSA-p25m-jpj4-qcrr`

- **Identifiers:** `GHSA-p25m-jpj4-qcrr` · `CVE-2023-4785` · `PYSEC-2026-1428`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 13 Sept 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 Sept 2023, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `grpc` (RubyGems): affected `>=1.56.0, <1.56.2 || >=1.55.0, <1.55.3 || >=1.54.0, <1.54.3 || >=1.53.0, <1.53.2`; fixed in `1.56.2`, `1.55.3`, `1.54.3`, `1.53.2`
- `grpcio` (PyPI): affected `>=1.55.0, <1.55.3 || >=1.54.0, <1.54.3 || >=1.53.0, <1.53.2`; fixed in `1.55.3`, `1.54.3`, `1.53.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (Google)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0077, the 55th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:36 UTC: First seen by agentprime
- 31 Oct 2026, 14:36 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-p25m-jpj4-qcrr)

## Sources

- [GitHub Advisory Database: GHSA-p25m-jpj4-qcrr](https://github.com/advisories/GHSA-p25m-jpj4-qcrr)
- [OSV: GHSA-p25m-jpj4-qcrr](https://osv.dev/vulnerability/GHSA-p25m-jpj4-qcrr)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-4785>
- <https://github.com/grpc/grpc/pull/33656>
- <https://github.com/grpc/grpc/pull/33667>
- <https://github.com/grpc/grpc/pull/33669>
- <https://github.com/grpc/grpc/pull/33670>
- <https://github.com/grpc/grpc/pull/33672>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/grpc/CVE-2023-4785.yml>
- <https://groups.google.com/g/grpc-io/c/LlLkB1CeE4U>
- <https://rubygems.org/gems/grpc/versions/1.53.2>
- <https://rubygems.org/gems/grpc/versions/1.54.3>
- <https://rubygems.org/gems/grpc/versions/1.55.3>
- <https://rubygems.org/gems/grpc/versions/1.56.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-p25m-jpj4-qcrr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-p25m-jpj4-qcrr/>. Everything for agents: <https://agentprime.io/llms.txt>.
