# Apache Tomcat may reject request containing invalid Content-Length header

Advisory record · `GHSA-p22x-g9px-3945`

- **Identifiers:** `GHSA-p22x-g9px-3945` · `BIT-tomcat-2022-42252` · `CVE-2022-42252`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md) · [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md)
- **Published:** 1 Nov 2022
- **Updated:** 23 Apr 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Nov 2022, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.tomcat.embed:tomcat-embed-core` (Maven): affected `>=8.5.0, <8.5.83 || >=9.0.0-M1, <9.0.68 || >=10.0.0-M1, <10.0.27 || >=10.1.0-M1, <10.1.1`; fixed in `8.5.83`, `9.0.68`, `10.0.27`, `10.1.1`
- `org.apache.tomcat:tomcat-coyote` (Maven): affected `>=9.0.0-M1, <9.0.68 || >=10.0.0-M1, <10.0.27 || >=10.1.0-M1, <10.1.1`; fixed in `9.0.68`, `10.0.27`, `10.1.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.018, the 78th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:13 UTC: First seen by agentprime
- 31 Oct 2026, 15:13 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-p22x-g9px-3945)

## Sources

- [GitHub Advisory Database: GHSA-p22x-g9px-3945](https://github.com/advisories/GHSA-p22x-g9px-3945)
- [OSV: GHSA-p22x-g9px-3945](https://osv.dev/vulnerability/GHSA-p22x-g9px-3945)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-42252>
- <https://github.com/apache/tomcat/commit/0d089a15047faf9cb3c82f80f4d28febd4798920>
- <https://github.com/apache/tomcat/commit/4c7f4fd09d2cc1692112ef70b8ee23a7a037ae77>
- <https://github.com/apache/tomcat/commit/a1c07906d8dcaf7957e5cc97f5cdbac7d18a205a>
- <https://github.com/apache/tomcat/commit/c9fe754e5d17e262dfbd3eab2a03ca96ff372dc3>
- <https://github.com/apache/tomcat>
- <https://lists.apache.org/thread/zzcxzvqfdqn515zfs3dxb7n8gty589sq>
- <https://security.gentoo.org/glsa/202305-37>
- <https://tomcat.apache.org/security-10.html>
- <https://tomcat.apache.org/security-8.html>
- <https://tomcat.apache.org/security-9.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-p22x-g9px-3945>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-p22x-g9px-3945/>. Everything for agents: <https://agentprime.io/llms.txt>.
