# ESP-IDF web_server basic auth bypass using empty or incomplete Authorization header

Advisory record · `GHSA-mxh2-ccgj-8635`

- **Identifiers:** `GHSA-mxh2-ccgj-8635` · `CVE-2025-57808` · `PYSEC-2026-1330`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-187](https://cwe.mitre.org/data/definitions/187.html) · [CWE-303](https://cwe.mitre.org/data/definitions/303.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-187](https://agentprime.io/advisories/tag/cwe-187.md)
- **Published:** 2 Sept 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Sept 2025, 16:46 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `esphome` (PyPI): affected `<2025.8.1`; fixed in `2025.8.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The ESPHome package, versions before 2025.8.1, has an authentication bypass in its web_server component when running on the ESP-IDF platform. The check can pass when the Authorization value is empty or only a partial match of the correct credentials, so an attacker on the local network can reach web_server functions, including OTA updates if enabled, without knowing the username or password. Upgrade to ESPHome 2025.8.1 or later; for older versions, disabling the web_server component on ESP-IDF devices is suggested.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.015, the 75th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:34 UTC: First seen by agentprime
- 31 Oct 2026, 14:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-mxh2-ccgj-8635)

## Sources

- [GitHub Advisory Database: GHSA-mxh2-ccgj-8635](https://github.com/advisories/GHSA-mxh2-ccgj-8635)
- [OSV: GHSA-mxh2-ccgj-8635](https://osv.dev/vulnerability/GHSA-mxh2-ccgj-8635)
- <https://github.com/esphome/esphome/security/advisories/GHSA-mxh2-ccgj-8635>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-57808>
- <https://github.com/esphome/esphome/commit/2aceb56606ec8afec5f49c92e140c8050a6ccbe5>
- <https://github.com/esphome/esphome>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-mxh2-ccgj-8635>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-mxh2-ccgj-8635/>. Everything for agents: <https://agentprime.io/llms.txt>.
