# Fiber has a Denial of Service Vulnerability via Route Parameter Overflow

Advisory record · `GHSA-mrq8-rjmw-wpq3`

- **Identifiers:** `GHSA-mrq8-rjmw-wpq3` · `CVE-2026-25882` · `GO-2026-4543`
- **State:** Confirmed
- **Severity:** CVSS 5.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-129](https://cwe.mitre.org/data/definitions/129.html)
- **Tags:** [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 24 Feb 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Feb 2026, 21:04 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/gofiber/fiber/v2` (Go): affected `<2.52.12`; fixed in `2.52.12`
- `github.com/gofiber/fiber/v3` (Go): affected `<3.1.0`; fixed in `3.1.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-mrq8-rjmw-wpq3 affects Fiber v2 before 2.52.12 and Fiber v3 before 3.1.0. A remote attacker can send one HTTP request to a route registered with more than 30 parameters and crash the application with a panic. Upgrade to Fiber v2.52.12 or v3.1.0.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.5 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0067, the 52nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-mrq8-rjmw-wpq3)

## Sources

- [GitHub Advisory Database: GHSA-mrq8-rjmw-wpq3](https://github.com/advisories/GHSA-mrq8-rjmw-wpq3)
- [OSV: GHSA-mrq8-rjmw-wpq3](https://osv.dev/vulnerability/GHSA-mrq8-rjmw-wpq3)
- <https://github.com/gofiber/fiber/security/advisories/GHSA-mrq8-rjmw-wpq3>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-25882>
- <https://github.com/gofiber/fiber/pull/3962>
- <https://github.com/gofiber/fiber>
- <https://github.com/gofiber/fiber/blob/main/path.go#L514>
- <https://github.com/gofiber/fiber/blob/v2/path.go#L516>
- <https://pkg.go.dev/vuln/GO-2026-4543>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-mrq8-rjmw-wpq3>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-mrq8-rjmw-wpq3/>. Everything for agents: <https://agentprime.io/llms.txt>.
