# GeoTools has unauthenticated SQL injection in the jsonArrayContains filter function against PostGIS layers

Advisory record · `GHSA-mqjf-5f49-2fjh`

- **Identifiers:** `GHSA-mqjf-5f49-2fjh` · `CVE-2026-76904`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-89](https://cwe.mitre.org/data/definitions/89.html)
- **Tags:** [SQL injection](https://agentprime.io/advisories/tag/sql-injection.md)
- **Published:** 21 Aug 2026
- **Updated:** 21 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Aug 2026, 20:25 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.geotools.jdbc:gt-jdbc-postgis` (Maven): affected `>=35.0, <35.1 || >=34.0, <34.5 || >=30.5, <33.6`; fixed in `35.1`, `34.5`, `33.6`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.040, the 90th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-mqjf-5f49-2fjh)

## Sources

- [GitHub Advisory Database: GHSA-mqjf-5f49-2fjh](https://github.com/advisories/GHSA-mqjf-5f49-2fjh)
- [OSV: GHSA-mqjf-5f49-2fjh](https://osv.dev/vulnerability/GHSA-mqjf-5f49-2fjh)
- <https://github.com/geotools/geotools/security/advisories/GHSA-mqjf-5f49-2fjh>
- <https://github.com/geotools/geotools/pull/5829>
- <https://github.com/geotools/geotools/commit/d821c4d321dd91c22e31fcd5b1ce676645da5176>
- <https://github.com/geotools/geotools>
- <https://github.com/geotools/geotools/releases/tag/33.6>
- <https://github.com/geotools/geotools/releases/tag/34.5>
- <https://github.com/geotools/geotools/releases/tag/35.1>
- <https://osgeo-org.atlassian.net/browse/GEOT-7589>
- <https://osgeo-org.atlassian.net/browse/GEOT-7958>
- <https://osgeo-org.atlassian.net/browse/GEOT-7959>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-mqjf-5f49-2fjh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-mqjf-5f49-2fjh/>. Everything for agents: <https://agentprime.io/llms.txt>.
