# Yarn untrusted search path vulnerability

Advisory record · `GHSA-mpwj-fcr6-x34c`

- **Identifiers:** `GHSA-mpwj-fcr6-x34c` · `CVE-2021-4435`
- **State:** Confirmed
- **Severity:** CVSS 7.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-426](https://cwe.mitre.org/data/definitions/426.html)
- **Tags:** [CWE-426](https://agentprime.io/advisories/tag/cwe-426.md)
- **Published:** 4 Feb 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 Feb 2024, 21:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `yarn` (npm): affected `<1.22.13`; fixed in `1.22.13`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.7 High, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`, from CNA (fedora)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0030, the 22nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 4 Feb 2024. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-mpwj-fcr6-x34c](https://github.com/advisories/GHSA-mpwj-fcr6-x34c)
- [OSV: GHSA-mpwj-fcr6-x34c](https://osv.dev/vulnerability/GHSA-mpwj-fcr6-x34c)
- <https://nvd.nist.gov/vuln/detail/CVE-2021-4435>
- <https://github.com/yarnpkg/yarn/commit/67fcce88935e45092ffa2674c08053f1ef5268a1>
- <https://access.redhat.com/security/cve/CVE-2021-4435>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2262284>
- <https://github.com/yarnpkg/yarn>
- <https://github.com/yarnpkg/yarn/releases/tag/v1.22.13>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-mpwj-fcr6-x34c>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-mpwj-fcr6-x34c/>. Everything for agents: <https://agentprime.io/llms.txt>.
