# Puppet uses predictable filenames, allowing arbitrary file overwrite

Advisory record · `GHSA-mpmx-gm5v-q789`

- **Identifiers:** `GHSA-mpmx-gm5v-q789` · `CVE-2011-3871`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-340](https://cwe.mitre.org/data/definitions/340.html)
- **Tags:** [CWE-340](https://agentprime.io/advisories/tag/cwe-340.md)
- **Published:** 14 May 2022
- **Updated:** 2 Dec 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 May 2022, 00:56 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `puppet` (RubyGems): affected `>=2.7.0, <2.7.5 || <2.6.11`; fixed in `2.7.5`, `2.6.11`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** 0.0034, the 27th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 14 May 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-mpmx-gm5v-q789](https://github.com/advisories/GHSA-mpmx-gm5v-q789)
- [OSV: GHSA-mpmx-gm5v-q789](https://osv.dev/vulnerability/GHSA-mpmx-gm5v-q789)
- <https://nvd.nist.gov/vuln/detail/CVE-2011-3871>
- <https://github.com/puppetlabs/puppet/commit/343c7bd381b63e042d437111718918f951d9b30d>
- <https://github.com/puppetlabs/puppet/commit/d76c30935460ded953792dfe49f72b8c5158e899>
- <https://github.com/puppetlabs/puppet>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2011-3871.yml>
- <https://puppet.com/security/cve/cve-2011-3871>
- <http://groups.google.com/group/puppet-announce/browse_thread/thread/91e3b46d2328a1cb>
- <http://lists.fedoraproject.org/pipermail/package-announce/2011-October/068053.html>
- <http://lists.fedoraproject.org/pipermail/package-announce/2011-October/068061.html>
- <http://lists.fedoraproject.org/pipermail/package-announce/2011-October/068093.html>
- <http://www.debian.org/security/2011/dsa-2314>
- <http://www.ubuntu.com/usn/USN-1223-1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-mpmx-gm5v-q789>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-mpmx-gm5v-q789/>. Everything for agents: <https://agentprime.io/llms.txt>.
