# Laravel Backpack CRUD: Stored XSS in the color column — the \`@if($column\['escaped'\])\` branches are inverted

Advisory record · `GHSA-mmg4-322v-6jvc`

- **Identifiers:** `GHSA-mmg4-322v-6jvc` · `CVE-2026-54181` · `PKSA-5phc-pmxf-y81y`
- **State:** Confirmed
- **Severity:** CVSS 5.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-1023](https://cwe.mitre.org/data/definitions/1023.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-1023](https://agentprime.io/advisories/tag/cwe-1023.md)
- **Published:** 20 Aug 2026
- **Updated:** 20 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Aug 2026, 18:38 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `backpack/crud` (Packagist): affected `>=6.0.0, <6.8.14 || >=7.0.0, <7.0.38`; fixed in `6.8.14`, `7.0.38`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Backpack CRUD versions 6.0.0 to before 6.8.14 and 7.0.0 to before 7.0.38 are vulnerable to stored cross-site scripting in the color column type, where values are rendered unescaped by default. An attacker who can write an arbitrary string into a color column can run JavaScript in the browser of any user who views the list, including administrators. Upgrade to 6.8.14 or 7.0.38. Until then, validate color values against a strict hex color pattern in the model before they are stored.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.4 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0031, the 24th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-mmg4-322v-6jvc)

## Sources

- [GitHub Advisory Database: GHSA-mmg4-322v-6jvc](https://github.com/advisories/GHSA-mmg4-322v-6jvc)
- [OSV: GHSA-mmg4-322v-6jvc](https://osv.dev/vulnerability/GHSA-mmg4-322v-6jvc)
- <https://github.com/Laravel-Backpack/CRUD/security/advisories/GHSA-mmg4-322v-6jvc>
- <https://github.com/Laravel-Backpack/CRUD>
- <https://github.com/Laravel-Backpack/CRUD/releases/tag/6.8.14>
- <https://github.com/Laravel-Backpack/CRUD/releases/tag/7.0.38>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-mmg4-322v-6jvc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-mmg4-322v-6jvc/>. Everything for agents: <https://agentprime.io/llms.txt>.
