# OpenTofu incorrectly validates excluded subdomain constraint in conjunction with TLS certificates containing wildcard SANs

Advisory record · `GHSA-mjcp-gpgx-ggcg`

- **Identifiers:** `GHSA-mjcp-gpgx-ggcg` · `GO-2025-4224`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-296](https://cwe.mitre.org/data/definitions/296.html) · [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [CWE-296](https://agentprime.io/advisories/tag/cwe-296.md) · [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 9 Dec 2025
- **Updated:** 15 Dec 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Dec 2025, 22:48 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/opentofu/opentofu` (Go): affected `<1.10.8`; fixed in `1.10.8`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 9 Dec 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-mjcp-gpgx-ggcg](https://github.com/advisories/GHSA-mjcp-gpgx-ggcg)
- [OSV: GHSA-mjcp-gpgx-ggcg](https://osv.dev/vulnerability/GHSA-mjcp-gpgx-ggcg)
- <https://github.com/opentofu/opentofu/security/advisories/GHSA-mjcp-gpgx-ggcg>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-61727>
- <https://github.com/opentofu/opentofu/issues/3546>
- <https://github.com/opentofu/opentofu>
- <https://github.com/opentofu/opentofu/releases/tag/v1.10.8>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-mjcp-gpgx-ggcg>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-mjcp-gpgx-ggcg/>. Everything for agents: <https://agentprime.io/llms.txt>.
