# proxy denial of service vulnerability

Advisory record · `GHSA-mj6p-3pc9-wf5m`

- **Identifiers:** `GHSA-mj6p-3pc9-wf5m` · `CVE-2023-2968`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-232](https://cwe.mitre.org/data/definitions/232.html)
- **Tags:** [CWE-232](https://agentprime.io/advisories/tag/cwe-232.md)
- **Published:** 30 May 2023
- **Updated:** 11 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 May 2023, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `proxy` (npm): affected `>=2.0.0, <2.1.1`; fixed in `2.1.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (JFROG)

- **CISA KEV:** Not listed.
- **EPSS:** 0.015, the 73rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 30 May 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-mj6p-3pc9-wf5m](https://github.com/advisories/GHSA-mj6p-3pc9-wf5m)
- [OSV: GHSA-mj6p-3pc9-wf5m](https://osv.dev/vulnerability/GHSA-mj6p-3pc9-wf5m)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-2968>
- <https://github.com/TooTallNate/proxy-agents/pull/178>
- <https://github.com/TooTallNate/proxy-agents/commit/25e0c931390eb8f41c5ceaca72820de9198ece39>
- <https://github.com/TooTallNate/proxy-agents>
- <https://research.jfrog.com/vulnerabilities/undefined-variable-usage-in-proxy-leads-to-remote-denial-of-service-xray-520917>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-mj6p-3pc9-wf5m>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-mj6p-3pc9-wf5m/>. Everything for agents: <https://agentprime.io/llms.txt>.
