# Drupal core allows Exploiting Incorrectly Configured Access Control Security Levels

Advisory record · `GHSA-mhpg-hpj5-73r2`

- **Identifiers:** `GHSA-mhpg-hpj5-73r2` · `BIT-drupal-2025-13083` · `CVE-2025-13083` · `DRUPAL-CORE-2025-008` · `PKSA-d8tb-wwz2-ctxk`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-525](https://cwe.mitre.org/data/definitions/525.html)
- **Tags:** [CWE-525](https://agentprime.io/advisories/tag/cwe-525.md)
- **Published:** 18 Nov 2025
- **Updated:** 3 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Nov 2025, 18:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `drupal/core` (Packagist): affected `>=8.0.0, <10.4.9 || >=10.5.0, <10.5.6 || >=11.0.0, <11.1.9 || >=11.2.0, <11.2.8 || >=7.0, <7.103`; fixed in `10.4.9`, `10.5.6`, `11.1.9`, `11.2.8`, `7.103`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0028, the 20th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 18 Nov 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-mhpg-hpj5-73r2](https://github.com/advisories/GHSA-mhpg-hpj5-73r2)
- [OSV: GHSA-mhpg-hpj5-73r2](https://osv.dev/vulnerability/GHSA-mhpg-hpj5-73r2)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-13083>
- <https://github.com/drupal/core>
- <https://www.drupal.org/sa-core-2025-008>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-mhpg-hpj5-73r2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-mhpg-hpj5-73r2/>. Everything for agents: <https://agentprime.io/llms.txt>.
