# Zend-Captcha Information Disclosure and Insufficient Entropy vulnerability

Advisory record · `GHSA-mg4x-prh7-g4mx`

- **Identifiers:** `GHSA-mg4x-prh7-g4mx` · `PKSA-kv74-yjnp-pcr9`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-331](https://cwe.mitre.org/data/definitions/331.html)
- **Tags:** [CWE-331](https://agentprime.io/advisories/tag/cwe-331.md)
- **Published:** 7 Jun 2024
- **Updated:** 4 Dec 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Jun 2024, 22:25 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `zendframework/zend-captcha` (Packagist): affected `>=2.0.0, <2.4.9 || >=2.5.0, <2.5.2`; fixed in `2.4.9`, `2.5.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Zend-Captcha versions from 2.0.0 before 2.4.9 and from 2.5.0 before 2.5.2 are affected. The Word CAPTCHA generator picks its characters with PHP's array_rand(), which relies on weak randomness, so an attacker who can brute-force that random number generation could recover CAPTCHA words. The source gives few details about the exact attack conditions. Upgrade to zend-captcha 2.4.9 or 2.5.2.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:28 UTC: First seen by agentprime
- 31 Oct 2026, 14:28 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-mg4x-prh7-g4mx)

## Sources

- [GitHub Advisory Database: GHSA-mg4x-prh7-g4mx](https://github.com/advisories/GHSA-mg4x-prh7-g4mx)
- [OSV: GHSA-mg4x-prh7-g4mx](https://osv.dev/vulnerability/GHSA-mg4x-prh7-g4mx)
- <https://github.com/zendframework/zend-captcha/commit/43c276df6e94e498bf530538aea53876a24fc47c>
- <https://github.com/zendframework/zend-captcha/commit/5561ef813bb4ad814e835343289dc5077d2eb262>
- <https://framework.zend.com/security/advisory/ZF2015-09>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zend-captcha/ZF2015-09.yaml>
- <https://github.com/zendframework/zend-captcha>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-mg4x-prh7-g4mx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-mg4x-prh7-g4mx/>. Everything for agents: <https://agentprime.io/llms.txt>.
