# crack does not properly restrict casts of string values

Advisory record · `GHSA-m7fq-cf8q-35q7`

- **Identifiers:** `GHSA-m7fq-cf8q-35q7` · `CVE-2013-1800`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-74](https://cwe.mitre.org/data/definitions/74.html) · [CWE-704](https://cwe.mitre.org/data/definitions/704.html)
- **Tags:** [Other injection](https://agentprime.io/advisories/tag/injection.md) · [CWE-704](https://agentprime.io/advisories/tag/cwe-704.md)
- **Published:** 24 Oct 2017
- **Updated:** 3 Dec 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Oct 2017, 18:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `crack` (RubyGems): affected `<0.3.2`; fixed in `0.3.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** 0.050, the 92nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 Oct 2017. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-m7fq-cf8q-35q7](https://github.com/advisories/GHSA-m7fq-cf8q-35q7)
- [OSV: GHSA-m7fq-cf8q-35q7](https://osv.dev/vulnerability/GHSA-m7fq-cf8q-35q7)
- <https://nvd.nist.gov/vuln/detail/CVE-2013-1800>
- <https://github.com/jnunemaker/crack/commit/e3da1212a1f84a898ee3601336d1dbbf118fb5f6>
- <https://bugzilla.novell.com/show_bug.cgi?id=804721>
- <https://bugzilla.redhat.com/show_bug.cgi?id=917236>
- <https://github.com/jnunemaker/crack>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/crack/CVE-2013-1800.yml>
- <https://support.cloud.engineyard.com/entries/22915701-january-14-2013-security-vulnerabilities-httparty-extlib-crack-nori-update-these-gems-immediately>
- <https://web.archive.org/web/20130203232028/https://support.cloud.engineyard.com/entries/22915701-january-14-2013-security-vulnerabilities-httparty-extlib-crack-nori-update-these-gems-immediately>
- <http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00003.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-m7fq-cf8q-35q7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-m7fq-cf8q-35q7/>. Everything for agents: <https://agentprime.io/llms.txt>.
