# Twitter-Post-Fetcher vulnerable to Use of Web Link to Untrusted Target with window.opener Access

Advisory record · `GHSA-m688-cx2p-rgq9`

- **Identifiers:** `GHSA-m688-cx2p-rgq9` · `CVE-2018-25058`
- **State:** Confirmed
- **Severity:** CVSS 4.2 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-1022](https://cwe.mitre.org/data/definitions/1022.html)
- **Tags:** [CWE-1022](https://agentprime.io/advisories/tag/cwe-1022.md)
- **Published:** 29 Dec 2022
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Dec 2022, 09:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `twitter-fetcher-js` (npm): affected `<18.0.0`; fixed in `18.0.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.2 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:L`, from CNA (VulDB)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0056, the 46th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 29 Dec 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-m688-cx2p-rgq9](https://github.com/advisories/GHSA-m688-cx2p-rgq9)
- [OSV: GHSA-m688-cx2p-rgq9](https://osv.dev/vulnerability/GHSA-m688-cx2p-rgq9)
- <https://nvd.nist.gov/vuln/detail/CVE-2018-25058>
- <https://github.com/jasonmayes/Twitter-Post-Fetcher/pull/170>
- <https://github.com/jasonmayes/Twitter-Post-Fetcher/commit/7d281c6fb5acbc29a2cad295262c1f0c19ca56f3>
- <https://github.com/jasonmayes/Twitter-Post-Fetcher>
- <https://github.com/jasonmayes/Twitter-Post-Fetcher/releases/tag/18.0.0>
- <https://vuldb.com/?ctiid.217017>
- <https://vuldb.com/?id.217017>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-m688-cx2p-rgq9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-m688-cx2p-rgq9/>. Everything for agents: <https://agentprime.io/llms.txt>.
