# Deno's deno_runtime vulnerable to interactive permission prompt spoofing via improper ANSI stripping

Advisory record · `GHSA-m4pq-fv2w-6hrw`

- **Identifiers:** `GHSA-m4pq-fv2w-6hrw` · `CVE-2024-27936`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-150](https://cwe.mitre.org/data/definitions/150.html)
- **Tags:** [CWE-150](https://agentprime.io/advisories/tag/cwe-150.md)
- **Published:** 5 Mar 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Mar 2024, 20:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `deno` (crates.io): affected `>=1.32.1, <1.41.0`; fixed in `1.41.0`
- `deno_runtime` (crates.io): affected `>=0.103.0, <0.147.0`; fixed in `0.147.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0094, the 61st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:17 UTC: First seen by agentprime
- 31 Oct 2026, 15:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-m4pq-fv2w-6hrw)

## Sources

- [GitHub Advisory Database: GHSA-m4pq-fv2w-6hrw](https://github.com/advisories/GHSA-m4pq-fv2w-6hrw)
- [OSV: GHSA-m4pq-fv2w-6hrw](https://osv.dev/vulnerability/GHSA-m4pq-fv2w-6hrw)
- <https://github.com/denoland/deno/security/advisories/GHSA-m4pq-fv2w-6hrw>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-27936>
- <https://github.com/denoland/deno/commit/78d430103a8f6931154ddbbe19d36f3b8630286d>
- <https://github.com/denoland/deno/commit/7e6b94231290020b55f1d08fb03ea8132781abc5>
- <https://github.com/denoland/deno>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-m4pq-fv2w-6hrw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-m4pq-fv2w-6hrw/>. Everything for agents: <https://agentprime.io/llms.txt>.
