# Netty vulnerable to HTTP Request Smuggling due to incorrect chunk size parsing

Advisory record · `GHSA-m4cv-j2px-7723`

- **Identifiers:** `GHSA-m4cv-j2px-7723` · `CVE-2026-42580`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-190](https://cwe.mitre.org/data/definitions/190.html) · [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 7 May 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 May 2026, 00:13 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.netty:netty-codec-http` (Maven): affected `>=4.2.0.Alpha1, <4.2.13.Final || <4.1.133.Final`; fixed in `4.2.13.Final`, `4.1.133.Final`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Netty's io.netty.handler.codec.http.HttpObjectDecoder in netty-codec-http, versions 4.2.0.Alpha1 up to 4.2.13.Final and 4.1.x before 4.1.133.Final, can overflow its chunk size calculation. A remote attacker who sends a crafted chunked request can smuggle a second HTTP request inside a chunked body. Upgrade to 4.2.13.Final or 4.1.133.Final.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0038, the 31st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-m4cv-j2px-7723)

## Sources

- [GitHub Advisory Database: GHSA-m4cv-j2px-7723](https://github.com/advisories/GHSA-m4cv-j2px-7723)
- [OSV: GHSA-m4cv-j2px-7723](https://osv.dev/vulnerability/GHSA-m4cv-j2px-7723)
- <https://github.com/netty/netty/security/advisories/GHSA-m4cv-j2px-7723>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-42580>
- <https://github.com/netty/netty>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-m4cv-j2px-7723>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-m4cv-j2px-7723/>. Everything for agents: <https://agentprime.io/llms.txt>.
