# papercrop does not properly handle crop input

Advisory record · `GHSA-m44r-gv6q-9j9r`

- **Identifiers:** `GHSA-m44r-gv6q-9j9r` · `CVE-2015-2784`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md)
- **Published:** 24 May 2022
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 May 2022, 17:06 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `papercrop` (RubyGems): affected `<0.3.0`; fixed in `0.3.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.018, the 78th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 May 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-m44r-gv6q-9j9r](https://github.com/advisories/GHSA-m44r-gv6q-9j9r)
- [OSV: GHSA-m44r-gv6q-9j9r](https://osv.dev/vulnerability/GHSA-m44r-gv6q-9j9r)
- <https://nvd.nist.gov/vuln/detail/CVE-2015-2784>
- <https://github.com/rsantamaria/papercrop/commit/b4ecd95debaf0a8712bd1d34def83f41fc6b3579>
- <https://github.com/rsantamaria/papercrop>
- <https://github.com/rsantamaria/papercrop/blob/master/CHANGELOG.md>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-m44r-gv6q-9j9r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-m44r-gv6q-9j9r/>. Everything for agents: <https://agentprime.io/llms.txt>.
