# Authenticated Local Privilege Escalation vulnerability in Intel Optimization for Tensorflow

Advisory record · `GHSA-m2f8-v8q4-3m59`

- **Identifiers:** `GHSA-m2f8-v8q4-3m59` · `CVE-2023-27506` · `PYSEC-2026-1465` · `PYSEC-2026-2523` · `PYSEC-2026-3385`
- **State:** Confirmed
- **Severity:** CVSS 5.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-92](https://cwe.mitre.org/data/definitions/92.html) · [CWE-119](https://cwe.mitre.org/data/definitions/119.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-92](https://agentprime.io/advisories/tag/cwe-92.md)
- **Published:** 11 Aug 2023
- **Updated:** 13 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 Aug 2023, 03:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `intel-tensorflow` (PyPI): affected `<2.12`; fixed in `2.12`
- `tensorflow-intel` (PyPI): affected `<2.12`; fixed in `2.12`
- `intel-tensorflow-avx512` (PyPI): affected `<2.12`; fixed in `2.12`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Intel Optimization for TensorFlow packages intel-tensorflow, tensorflow-intel and intel-tensorflow-avx512 are affected in versions before 2.12. An authenticated local user may be able to escalate privileges through improper buffer restrictions. Upgrade to version 2.12 or later.

Written 6 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.5 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:H/A:L`, from CNA (intel)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0016, the 5th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:00 UTC: First seen by agentprime
- 31 Oct 2026, 15:00 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-m2f8-v8q4-3m59)

## Sources

- [GitHub Advisory Database: GHSA-m2f8-v8q4-3m59](https://github.com/advisories/GHSA-m2f8-v8q4-3m59)
- [OSV: GHSA-m2f8-v8q4-3m59](https://osv.dev/vulnerability/GHSA-m2f8-v8q4-3m59)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-27506>
- <http://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00840.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-m2f8-v8q4-3m59>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-m2f8-v8q4-3m59/>. Everything for agents: <https://agentprime.io/llms.txt>.
