# vm2 CLI provides no sandbox isolation - host-realm require() is reachable from sandboxed scripts

Advisory record · `GHSA-jxxv-8r27-vm4p`

- **Identifiers:** `GHSA-jxxv-8r27-vm4p` · `CVE-2026-92950`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-453](https://cwe.mitre.org/data/definitions/453.html) · [CWE-829](https://cwe.mitre.org/data/definitions/829.html) · [CWE-1188](https://cwe.mitre.org/data/definitions/1188.html)
- **Tags:** [CWE-453](https://agentprime.io/advisories/tag/cwe-453.md) · [CWE-829](https://agentprime.io/advisories/tag/cwe-829.md) · [CWE-1188](https://agentprime.io/advisories/tag/cwe-1188.md)
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Oct 2026, 15:40 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `vm2` (npm): affected `<3.11.7`; fixed in `3.11.7`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The vm2 command-line tool (npm package vm2, versions below 3.11.7) runs the supplied script with default settings that load relative and absolute require() targets through the host Node.js require(), so the script's module body executes in the host process before sandbox isolation applies. An attacker who can supply a script file that a user runs with the vm2 CLI can execute arbitrary code as that user, with access to the host filesystem, child processes and network. Upgrade vm2 to version 3.11.7 or later, which is the listed fixed version.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0020, the 9th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:34 UTC: First seen by agentprime
- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jxxv-8r27-vm4p)

## Sources

- [GitHub Advisory Database: GHSA-jxxv-8r27-vm4p](https://github.com/advisories/GHSA-jxxv-8r27-vm4p)
- [OSV: GHSA-jxxv-8r27-vm4p](https://osv.dev/vulnerability/GHSA-jxxv-8r27-vm4p)
- <https://github.com/patriksimek/vm2/security/advisories/GHSA-jxxv-8r27-vm4p>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-92950>
- <https://github.com/patriksimek/vm2/commit/903017c8a1eae9aba947ec854468b48155e79f86>
- <https://github.com/patriksimek/vm2>
- <https://github.com/patriksimek/vm2/releases/tag/v3.11.7>
- <https://www.vulncheck.com/advisories/vm2-before-3.11.7-sandbox-escape-via-cli-require>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jxxv-8r27-vm4p>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jxxv-8r27-vm4p/>. Everything for agents: <https://agentprime.io/llms.txt>.
