# Apollo Portal: There is a risk of unauthorized access to the Apollo configuration center

Advisory record · `GHSA-jxpj-9j24-w337`

- **Identifiers:** `GHSA-jxpj-9j24-w337` · `CVE-2025-32781`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-639](https://cwe.mitre.org/data/definitions/639.html) · [CWE-862](https://cwe.mitre.org/data/definitions/862.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 13 Jul 2026
- **Updated:** 20 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 Jul 2026, 16:47 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `com.ctrip.framework.apollo:apollo` (Maven): affected `all versions`; no fixed version yet

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apollo Portal (Maven package com.ctrip.framework.apollo:apollo) versions before 2.5.0 are affected when configView.memberOnly.envs is enabled. An authenticated low-privileged user who obtains or guesses a valid release ID can read configuration from applications and namespaces they are not authorized to view, which may include credentials or service endpoints. Upgrade to Apollo 2.5.0 or later; the source lists no workaround beyond backporting the fix and restricting Portal access to trusted users.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0042, the 36th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jxpj-9j24-w337)

## Sources

- [GitHub Advisory Database: GHSA-jxpj-9j24-w337](https://github.com/advisories/GHSA-jxpj-9j24-w337)
- [OSV: GHSA-jxpj-9j24-w337](https://osv.dev/vulnerability/GHSA-jxpj-9j24-w337)
- <https://github.com/apolloconfig/apollo/security/advisories/GHSA-jxpj-9j24-w337>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-32781>
- <https://github.com/apolloconfig/apollo/pull/5378>
- <https://github.com/apolloconfig/apollo/commit/362735ded4f13b62f6ab9df135d7096066e8e291>
- <https://github.com/apolloconfig/apollo>
- <https://github.com/apolloconfig/apollo/releases/tag/v2.5.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jxpj-9j24-w337>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jxpj-9j24-w337/>. Everything for agents: <https://agentprime.io/llms.txt>.
