# Devise does not properly perform type conversion when performing database queries

Advisory record · `GHSA-jxhw-mg8m-2pj8`

- **Identifiers:** `GHSA-jxhw-mg8m-2pj8` · `CVE-2013-0233`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-704](https://cwe.mitre.org/data/definitions/704.html)
- **Tags:** [CWE-704](https://agentprime.io/advisories/tag/cwe-704.md)
- **Published:** 24 Oct 2017
- **Updated:** 3 Dec 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Oct 2017, 18:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `devise` (RubyGems): affected `>=2.2.0, <2.2.3 || >=2.1.0, <2.1.3 || >=2.0.0, <2.0.5 || >=1.5.0, <1.5.4`; fixed in `2.2.3`, `2.1.3`, `2.0.5`, `1.5.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** 0.14, the 96th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 Oct 2017. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-jxhw-mg8m-2pj8](https://github.com/advisories/GHSA-jxhw-mg8m-2pj8)
- [OSV: GHSA-jxhw-mg8m-2pj8](https://osv.dev/vulnerability/GHSA-jxhw-mg8m-2pj8)
- <https://nvd.nist.gov/vuln/detail/CVE-2013-0233>
- <https://github.com/Snorby/snorby/issues/261>
- <https://web.archive.org/web/20140726005251/http://www.phenoelit.org/blog/archives/2013/02/05/mysql_madness_and_rails/index.html>
- <https://web.archive.org/web/20200229103406/http://www.securityfocus.com/bid/57577>
- <http://blog.plataformatec.com.br/2013/01/security-announcement-devise-v2-2-3-v2-1-3-v2-0-5-and-v1-5-3-released>
- <http://lists.opensuse.org/opensuse-updates/2013-03/msg00000.html>
- <http://www.metasploit.com/modules/auxiliary/admin/http/rails_devise_pass_reset>
- <http://www.openwall.com/lists/oss-security/2013/01/29/3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jxhw-mg8m-2pj8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jxhw-mg8m-2pj8/>. Everything for agents: <https://agentprime.io/llms.txt>.
