# scikit-learn sensitive data leakage vulnerability

Advisory record · `GHSA-jw8x-6495-233v`

- **Identifiers:** `GHSA-jw8x-6495-233v` · `CVE-2024-5206` · `PYSEC-2024-110`
- **State:** Confirmed
- **Severity:** CVSS 4.7 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-921](https://cwe.mitre.org/data/definitions/921.html) · [CWE-922](https://cwe.mitre.org/data/definitions/922.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-921](https://agentprime.io/advisories/tag/cwe-921.md)
- **Published:** 6 Jun 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Jun 2024, 21:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `scikit-learn` (PyPI): affected `<1.5.0`; fixed in `1.5.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> scikit-learn versions before 1.5.0 are affected, specifically TfidfVectorizer in versions up to and including 1.4.1.post1. TfidfVectorizer stores all training tokens in its stop_words\_ attribute, so sensitive values such as passwords or keys present in training data may be retained and exposed to anyone who can access the fitted vectorizer. Upgrade scikit-learn to version 1.5.0 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.7 Medium, CVSS 3.0: `CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`, from CNA (@huntr_ai)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0019, the 8th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:35 UTC: First seen by agentprime
- 31 Oct 2026, 14:35 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jw8x-6495-233v)

## Sources

- [GitHub Advisory Database: GHSA-jw8x-6495-233v](https://github.com/advisories/GHSA-jw8x-6495-233v)
- [OSV: GHSA-jw8x-6495-233v](https://osv.dev/vulnerability/GHSA-jw8x-6495-233v)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-5206>
- <https://github.com/scikit-learn/scikit-learn/commit/70ca21f106b603b611da73012c9ade7cd8e438b8>
- <https://github.com/pypa/advisory-database/tree/main/vulns/scikit-learn/PYSEC-2024-110.yaml>
- <https://github.com/scikit-learn/scikit-learn>
- <https://huntr.com/bounties/14bc0917-a85b-4106-a170-d09d5191517c>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jw8x-6495-233v>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jw8x-6495-233v/>. Everything for agents: <https://agentprime.io/llms.txt>.
