# OpenStack Ironic allows Boot Script Injection

Advisory record · `GHSA-jrh2-f5jc-xpgr`

- **Identifiers:** `GHSA-jrh2-f5jc-xpgr` · `CVE-2026-46447` · `PYSEC-2026-3471`
- **State:** Confirmed
- **Severity:** CVSS 5.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-669](https://cwe.mitre.org/data/definitions/669.html)
- **Tags:** [CWE-669](https://agentprime.io/advisories/tag/cwe-669.md)
- **Published:** 4 Jun 2026
- **Updated:** 23 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 Jun 2026, 00:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ironic` (PyPI): affected `>=17.0.0, <26.1.7 || >=27.0.0, <29.0.6 || >=30.0.0, <32.0.2 || >=33.0.0, <35.0.2`; fixed in `26.1.7`, `29.0.6`, `32.0.2`, `35.0.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Ironic versions from 17.0.0 up to (but not including) 26.1.7, 27.0.0 through 29.0.5, 30.0.0 through 32.0.1, and 33.0.0 through 35.0.1 are affected by a boot script injection vulnerability. The source gives few details about how an attacker would exploit it or what access they need. Upgrade to 26.1.7, 29.0.6, 32.0.2, or 35.0.2, depending on your release line.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N`, from CNA (mitre)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0026, the 18th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:41 UTC: First seen by agentprime
- 31 Oct 2026, 14:41 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jrh2-f5jc-xpgr)

## Sources

- [GitHub Advisory Database: GHSA-jrh2-f5jc-xpgr](https://github.com/advisories/GHSA-jrh2-f5jc-xpgr)
- [OSV: GHSA-jrh2-f5jc-xpgr](https://osv.dev/vulnerability/GHSA-jrh2-f5jc-xpgr)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-46447>
- <https://bugs.launchpad.net/ironic/+bug/2150624>
- <https://github.com/openstack/ironic>
- <https://security.openstack.org/ossa/OSSA-2026-017.html>
- <http://www.openwall.com/lists/oss-security/2026/06/03/11>
- <http://www.openwall.com/lists/oss-security/2026/06/15/9>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jrh2-f5jc-xpgr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jrh2-f5jc-xpgr/>. Everything for agents: <https://agentprime.io/llms.txt>.
