# Kimai: Username enumeration via timing on X-AUTH-USER

Advisory record · `GHSA-jrc6-fmhw-fpq2`

- **Identifiers:** `GHSA-jrc6-fmhw-fpq2` · `CVE-2026-80199` · `PKSA-v9zg-kkkv-rs7x`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-208](https://cwe.mitre.org/data/definitions/208.html)
- **Tags:** [CWE-208](https://agentprime.io/advisories/tag/cwe-208.md)
- **Published:** 17 Apr 2026
- **Updated:** 27 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Apr 2026, 22:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `kimai/kimai` (Packagist): affected `<2.54.0`; fixed in `2.54.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Kimai versions before 2.54.0 (kimai/kimai on Packagist) leak whether a username exists through response timing in the API token authenticator, because a missing user skips the password hash check and returns about 25 ms faster. An unauthenticated attacker who can reach the API can repeatedly probe usernames via the legacy X-AUTH-USER header, which is accepted by default in 2.x and has no login throttling. The source notes the response body and status are identical and the impact is limited, and it says to upgrade to 2.54.0, which is the fixed version.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0031, the 23rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jrc6-fmhw-fpq2)

## Sources

- [GitHub Advisory Database: GHSA-jrc6-fmhw-fpq2](https://github.com/advisories/GHSA-jrc6-fmhw-fpq2)
- [OSV: GHSA-jrc6-fmhw-fpq2](https://osv.dev/vulnerability/GHSA-jrc6-fmhw-fpq2)
- <https://github.com/kimai/kimai/security/advisories/GHSA-jrc6-fmhw-fpq2>
- <https://github.com/kimai/kimai>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jrc6-fmhw-fpq2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jrc6-fmhw-fpq2/>. Everything for agents: <https://agentprime.io/llms.txt>.
