# Kimai: Default APP_SECRET in Docker Image Enables Cookie Forgery and Account Takeover

Advisory record · `GHSA-jr9p-4h4j-6c58`

- **Identifiers:** `GHSA-jr9p-4h4j-6c58` · `CVE-2026-52824` · `PKSA-rg27-2yxz-ng1q`
- **State:** Confirmed
- **Severity:** CVSS 9.1 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-1188](https://cwe.mitre.org/data/definitions/1188.html)
- **Tags:** [CWE-1188](https://agentprime.io/advisories/tag/cwe-1188.md)
- **Published:** 14 Jul 2026
- **Updated:** 14 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Jul 2026, 00:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.1: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `kimai/kimai` (Packagist): affected `<2.58.0`; fixed in `2.58.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Kimai (Packagist package kimai/kimai) versions before 2.58.0 are affected when deployed from the official Docker image without setting APP_SECRET, because the image ships with a publicly known default value. An unauthenticated attacker who can reach the instance may be able to forge signed cookies and login links and take over accounts, including super_admin, if the username and account ID are known and the account has no active 2FA. Upgrade to 2.58.0 or later, and set APP_SECRET to a unique random value if you run the Docker image.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.1 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.013, the 71st percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:25 UTC: First seen by agentprime
- 31 Oct 2026, 14:25 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jr9p-4h4j-6c58)

## Sources

- [GitHub Advisory Database: GHSA-jr9p-4h4j-6c58](https://github.com/advisories/GHSA-jr9p-4h4j-6c58)
- [OSV: GHSA-jr9p-4h4j-6c58](https://osv.dev/vulnerability/GHSA-jr9p-4h4j-6c58)
- <https://github.com/kimai/kimai/security/advisories/GHSA-jr9p-4h4j-6c58>
- <https://github.com/kimai/kimai>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jr9p-4h4j-6c58>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jr9p-4h4j-6c58/>. Everything for agents: <https://agentprime.io/llms.txt>.
