# Apache SIS has Improper Restriction of XML External Entity Reference vulnerability

Advisory record · `GHSA-jqmr-2pg9-vfx7`

- **Identifiers:** `GHSA-jqmr-2pg9-vfx7` · `CVE-2025-68280`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-611](https://cwe.mitre.org/data/definitions/611.html)
- **Tags:** [XML external entities (XXE)](https://agentprime.io/advisories/tag/xxe.md)
- **Published:** 5 Jan 2026
- **Updated:** 3 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Jan 2026, 15:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.sis.core:sis-metadata` (Maven): affected `>=0.4, <1.6`; fixed in `1.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache SIS (Maven package org.apache.sis.core:sis-metadata) versions 0.4 through 1.5 are vulnerable to XML external entity injection when parsing GeoTIFF files with DGIWG GEO_METADATA tags, ISO 19115 XML metadata, GML coordinate reference systems, or GPX files. An attacker who can supply such a file can read the contents of local files on the server. Upgrade to version 1.6, which fixes the issue. As a workaround, set the javax.xml.accessExternalDTD system property to restrict external protocols when launching Java.

Written 7 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0070, the 53rd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:09 UTC: First seen by agentprime
- 31 Oct 2026, 15:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jqmr-2pg9-vfx7)

## Sources

- [GitHub Advisory Database: GHSA-jqmr-2pg9-vfx7](https://github.com/advisories/GHSA-jqmr-2pg9-vfx7)
- [OSV: GHSA-jqmr-2pg9-vfx7](https://osv.dev/vulnerability/GHSA-jqmr-2pg9-vfx7)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-68280>
- <https://github.com/apache/sis>
- <https://lists.apache.org/thread/s4ggy3zbtrrn93glgo2vn52lgcxk4bp4>
- <http://www.openwall.com/lists/oss-security/2026/01/05/11>
- <http://www.openwall.com/lists/oss-security/2026/01/05/7>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jqmr-2pg9-vfx7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jqmr-2pg9-vfx7/>. Everything for agents: <https://agentprime.io/llms.txt>.
