# proxy-addr vulnerable to IP spoofing via IPv4-mapped IPv6 trust subnet

Advisory record · `GHSA-jqcg-44mw-7w3h`

- **Identifiers:** `GHSA-jqcg-44mw-7w3h` · `CVE-2026-90711`
- **State:** Confirmed
- **Severity:** CVSS 9.1 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-290](https://cwe.mitre.org/data/definitions/290.html) · [CWE-348](https://cwe.mitre.org/data/definitions/348.html) · [CWE-697](https://cwe.mitre.org/data/definitions/697.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-348](https://agentprime.io/advisories/tag/cwe-348.md) · [CWE-697](https://agentprime.io/advisories/tag/cwe-697.md)
- **Published:** 5 Oct 2026
- **Updated:** 5 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Oct 2026, 23:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.1: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `proxy-addr` (npm): affected `>=1.1.0, <2.0.8`; fixed in `2.0.8`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.1 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0026, the 17th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:34 UTC: First seen by agentprime
- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jqcg-44mw-7w3h)

## Sources

- [GitHub Advisory Database: GHSA-jqcg-44mw-7w3h](https://github.com/advisories/GHSA-jqcg-44mw-7w3h)
- [OSV: GHSA-jqcg-44mw-7w3h](https://osv.dev/vulnerability/GHSA-jqcg-44mw-7w3h)
- <https://github.com/jshttp/proxy-addr/security/advisories/GHSA-jqcg-44mw-7w3h>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-90711>
- <https://github.com/jshttp/proxy-addr/commit/780911d84d18e2c5fa008ed0c0d387631ec11965>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/jshttp/proxy-addr>
- <https://github.com/jshttp/proxy-addr/releases/tag/v2.0.8>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jqcg-44mw-7w3h>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jqcg-44mw-7w3h/>. Everything for agents: <https://agentprime.io/llms.txt>.
