# Seg fault in \`ndarray_tensor_bridge\` due to zero and large inputs

Advisory record · `GHSA-jq6x-99hj-q636`

- **Identifiers:** `GHSA-jq6x-99hj-q636` · `BIT-tensorflow-2022-41884` · `CVE-2022-41884` · `PYSEC-2026-1013` · `PYSEC-2026-3208` · `PYSEC-2026-3345`
- **State:** Confirmed
- **Severity:** CVSS 4.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-670](https://cwe.mitre.org/data/definitions/670.html)
- **Tags:** [CWE-670](https://agentprime.io/advisories/tag/cwe-670.md)
- **Published:** 21 Nov 2022
- **Updated:** 13 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Nov 2022, 20:39 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `tensorflow` (PyPI): affected `<2.8.4 || >=2.9.0, <2.9.3 || >=2.10.0, <2.10.1`; fixed in `2.8.4`, `2.9.3`, `2.10.1`
- `tensorflow-cpu` (PyPI): affected `<2.8.4 || >=2.9.0, <2.9.3 || >=2.10.0, <2.10.1`; fixed in `2.8.4`, `2.9.3`, `2.10.1`
- `tensorflow-gpu` (PyPI): affected `<2.8.4 || >=2.9.0, <2.9.3 || >=2.10.0, <2.10.1`; fixed in `2.8.4`, `2.9.3`, `2.10.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Seg fault in tensorflow, tensorflow-cpu and tensorflow-gpu versions before 2.8.4, from 2.9.0 before 2.9.3, and from 2.10.0 before 2.10.1 can be triggered by creating a numpy array with a shape that contains a zero dimension and other dimensions whose product is very large. The source does not describe the attacker's required access. Upgrade to tensorflow 2.8.4, 2.9.3, 2.10.1 or later, or to tensorflow-cpu or tensorflow-gpu at the same versions.

Written 6 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0037, the 31st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:01 UTC: First seen by agentprime
- 31 Oct 2026, 15:01 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jq6x-99hj-q636)

## Sources

- [GitHub Advisory Database: GHSA-jq6x-99hj-q636](https://github.com/advisories/GHSA-jq6x-99hj-q636)
- [OSV: GHSA-jq6x-99hj-q636](https://osv.dev/vulnerability/GHSA-jq6x-99hj-q636)
- <https://github.com/tensorflow/tensorflow/security/advisories/GHSA-jq6x-99hj-q636>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-41884>
- <https://github.com/tensorflow/tensorflow/commit/2b56169c16e375c521a3bc8ea658811cc0793784>
- <https://github.com/tensorflow/tensorflow>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jq6x-99hj-q636>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jq6x-99hj-q636/>. Everything for agents: <https://agentprime.io/llms.txt>.
