# pip Vulnerable to Inclusion of Functionality from Untrusted Control Sphere

Advisory record · `GHSA-jp4c-xjxw-mgf9`

- **Identifiers:** `GHSA-jp4c-xjxw-mgf9` · `CVE-2026-6357` · `PYSEC-2026-2876`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-829](https://cwe.mitre.org/data/definitions/829.html)
- **Tags:** [CWE-829](https://agentprime.io/advisories/tag/cwe-829.md)
- **Published:** 27 Apr 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Apr 2026, 15:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pip` (PyPI): affected `<26.1`; fixed in `26.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> pip versions before 26.1 can run its self-update check after installing wheel files, and that check imports well-known Python module names. An attacker who can get a malicious wheel installed could have it place a module under one of those names, which pip would then import. Upgrade to pip 26.1, which runs the self-update check before wheels are installed. Users should still review package contents before installing them.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`, from CNA (PSF)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0014, the 3rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:34 UTC: First seen by agentprime
- 31 Oct 2026, 14:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jp4c-xjxw-mgf9)

## Sources

- [GitHub Advisory Database: GHSA-jp4c-xjxw-mgf9](https://github.com/advisories/GHSA-jp4c-xjxw-mgf9)
- [OSV: GHSA-jp4c-xjxw-mgf9](https://osv.dev/vulnerability/GHSA-jp4c-xjxw-mgf9)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-6357>
- <https://github.com/pypa/pip/pull/13923>
- <https://github.com/pypa/pip/commit/b369bfc96cc524e00c267e1693290e6599c36bad>
- <https://github.com/pypa/pip>
- <https://ichard26.github.io/blog/2026/04/whats-new-in-pip-26.1/#security-fixes>
- <http://www.openwall.com/lists/oss-security/2026/04/27/7>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jp4c-xjxw-mgf9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jp4c-xjxw-mgf9/>. Everything for agents: <https://agentprime.io/llms.txt>.
