# Wagtail: Improper restriction handling on Page translation API endpoint

Advisory record · `GHSA-jm5p-837g-rv8g`

- **Identifiers:** `GHSA-jm5p-837g-rv8g`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-280](https://cwe.mitre.org/data/definitions/280.html)
- **Tags:** [CWE-280](https://agentprime.io/advisories/tag/cwe-280.md)
- **Published:** 20 Aug 2026
- **Updated:** 26 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Aug 2026, 18:45 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `wagtail` (PyPI): affected `<7.0.9 || >=7.1rc1, <7.3.4 || >=7.4rc1, <7.4.3 || >=8.0rc1, <8.0rc2`; fixed in `7.0.9`, `7.3.4`, `7.4.3`, `8.0rc2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Wagtail (PyPI package wagtail) versions 7.0.9 to before 7.1, 7.1rc1 to before 7.3.4, 7.4rc1 to before 7.4.3, and 8.0rc1 before 8.0rc2 are affected. A CMS user who has the "submit translations" permission can use the Admin API's "copy for translation" endpoint to copy an existing page they do not have edit access to, which lets them view that page's contents. Upgrade to Wagtail 7.0.9, 7.3.4, 7.4.3, or 8.0rc2, depending on the release line in use.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jm5p-837g-rv8g)

## Sources

- [GitHub Advisory Database: GHSA-jm5p-837g-rv8g](https://github.com/advisories/GHSA-jm5p-837g-rv8g)
- [OSV: GHSA-jm5p-837g-rv8g](https://osv.dev/vulnerability/GHSA-jm5p-837g-rv8g)
- <https://github.com/wagtail/wagtail/security/advisories/GHSA-jm5p-837g-rv8g>
- <https://github.com/wagtail/wagtail>
- <https://github.com/wagtail/wagtail/releases/tag/v7.0.9>
- <https://github.com/wagtail/wagtail/releases/tag/v7.3.4>
- <https://github.com/wagtail/wagtail/releases/tag/v7.4.3>
- <https://github.com/wagtail/wagtail/releases/tag/v8.0rc2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jm5p-837g-rv8g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jm5p-837g-rv8g/>. Everything for agents: <https://agentprime.io/llms.txt>.
