# Symfony Cryptographic Vulnerability

Advisory record · `GHSA-jjx5-fq5g-8xpc`

- **Identifiers:** `GHSA-jjx5-fq5g-8xpc` · `CVE-2016-1902` · `PKSA-c8q4-qf8b-nmtq` · `PKSA-cdq8-87w8-19rq` · `PKSA-dc8v-9qff-bx8y`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-332](https://cwe.mitre.org/data/definitions/332.html)
- **Tags:** [CWE-332](https://agentprime.io/advisories/tag/cwe-332.md)
- **Published:** 17 May 2022
- **Updated:** 18 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 May 2022, 03:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `symfony/security-core` (Packagist): affected `>=2.4.0, <2.6.13 || >=2.7.0, <2.7.9`; fixed in `2.6.13`, `2.7.9`
- `symfony/security` (Packagist): affected `>=2.3.0, <2.3.37 || >=2.4.0, <2.6.13 || >=2.7.0, <2.7.9`; fixed in `2.3.37`, `2.6.13`, `2.7.9`
- `symfony/symfony` (Packagist): affected `>=2.3.0, <2.3.37 || >=2.4.0, <2.6.13 || >=2.7.0, <2.7.9`; fixed in `2.3.37`, `2.6.13`, `2.7.9`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.019, the 79th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:30 UTC: First seen by agentprime
- 31 Oct 2026, 14:30 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jjx5-fq5g-8xpc)

## Sources

- [GitHub Advisory Database: GHSA-jjx5-fq5g-8xpc](https://github.com/advisories/GHSA-jjx5-fq5g-8xpc)
- [OSV: GHSA-jjx5-fq5g-8xpc](https://osv.dev/vulnerability/GHSA-jjx5-fq5g-8xpc)
- <https://nvd.nist.gov/vuln/detail/CVE-2016-1902>
- <https://github.com/symfony/symfony/pull/17359>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-core/CVE-2016-1902.yaml>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security/CVE-2016-1902.yaml>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2016-1902.yaml>
- <https://symfony.com/cve-2016-1902>
- <https://www.landaire.net/blog/cve-2016-1902-symfony-securerandom>
- <http://symfony.com/blog/cve-2016-1902-securerandom-s-fallback-not-secure-when-openssl-fails>
- <http://www.debian.org/security/2016/dsa-3588>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jjx5-fq5g-8xpc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jjx5-fq5g-8xpc/>. Everything for agents: <https://agentprime.io/llms.txt>.
