# RabbitMQ Java client has frame-level OOM: Math.min(maxInboundMessageBodySize, 0) defeats frame size enforcement

Advisory record · `GHSA-jh4v-gfqj-7rhx`

- **Identifiers:** `GHSA-jh4v-gfqj-7rhx` · `CVE-2026-75516`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 17 Sept 2026
- **Updated:** 17 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Sept 2026, 14:52 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `com.rabbitmq:amqp-client` (Maven): affected `<5.34.0`; fixed in `5.34.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The RabbitMQ Java client (com.rabbitmq:amqp-client, Maven) versions before 5.34.0 are affected. When the negotiated frame-max is 0, the client's frame size limit is disabled, so a malicious AMQP server or man-in-the-middle can send a single oversized frame that causes the client to allocate up to about 2 GB and crash with an out-of-memory error. Upgrade to version 5.34.0 or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0055, the 46th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jh4v-gfqj-7rhx)

## Sources

- [GitHub Advisory Database: GHSA-jh4v-gfqj-7rhx](https://github.com/advisories/GHSA-jh4v-gfqj-7rhx)
- [OSV: GHSA-jh4v-gfqj-7rhx](https://osv.dev/vulnerability/GHSA-jh4v-gfqj-7rhx)
- <https://github.com/rabbitmq/rabbitmq-java-client/security/advisories/GHSA-jh4v-gfqj-7rhx>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-75516>
- <https://github.com/rabbitmq/rabbitmq-java-client/pull/2015>
- <https://github.com/rabbitmq/rabbitmq-java-client/pull/2016>
- <https://github.com/rabbitmq/rabbitmq-java-client/commit/6d7c2bfe89796ca34d3531098fb59dd657fea39e>
- <https://github.com/rabbitmq/rabbitmq-java-client/commit/e7f10bf99aee103dd9f64b3e52a725fc9f9d3763>
- <https://github.com/rabbitmq/rabbitmq-java-client>
- <https://github.com/rabbitmq/rabbitmq-java-client/releases/tag/v5.34.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jh4v-gfqj-7rhx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jh4v-gfqj-7rhx/>. Everything for agents: <https://agentprime.io/llms.txt>.
