# pypdf can exhaust RAM via manipulated LZWDecode streams

Advisory record · `GHSA-jfx9-29x2-rv3j`

- **Identifiers:** `GHSA-jfx9-29x2-rv3j` · `CVE-2025-62708` · `PYSEC-2026-1831`
- **State:** Confirmed
- **Severity:** CVSS 6.6 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-409](https://cwe.mitre.org/data/definitions/409.html)
- **Tags:** [CWE-409](https://agentprime.io/advisories/tag/cwe-409.md)
- **Published:** 22 Oct 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Oct 2025, 19:40 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pypdf` (PyPI): affected `<6.1.3`; fixed in `6.1.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> pypdf versions before 6.1.3 can be made to use large amounts of memory. An attacker who supplies a crafted PDF can trigger this when the content stream of a page using the LZWDecode filter is parsed, so a user opening or processing such a file is affected. Upgrade to pypdf 6.1.3 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.6 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0044, the 38th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 22 Oct 2025, 22:15 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2025-62708)
- 31 Oct 2026, 14:34 UTC: First seen by agentprime
- 31 Oct 2026, 14:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jfx9-29x2-rv3j)

## Sources

- [GitHub Advisory Database: GHSA-jfx9-29x2-rv3j](https://github.com/advisories/GHSA-jfx9-29x2-rv3j)
- [OSV: GHSA-jfx9-29x2-rv3j](https://osv.dev/vulnerability/GHSA-jfx9-29x2-rv3j)
- <https://github.com/py-pdf/pypdf/security/advisories/GHSA-jfx9-29x2-rv3j>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-62708>
- <https://github.com/py-pdf/pypdf/pull/3502>
- <https://github.com/py-pdf/pypdf/commit/e51d07807ffcdaf18077b9486dadb3dc05b368da>
- <https://github.com/py-pdf/pypdf>
- <https://github.com/py-pdf/pypdf/releases/tag/6.1.3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jfx9-29x2-rv3j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jfx9-29x2-rv3j/>. Everything for agents: <https://agentprime.io/llms.txt>.
