# Heap buffer overflow caused by rounding

Advisory record · `GHSA-jfp7-4j67-8r3q`

- **Identifiers:** `GHSA-jfp7-4j67-8r3q` · `BIT-tensorflow-2021-29529` · `CVE-2021-29529` · `PYSEC-2021-166` · `PYSEC-2021-457` · `PYSEC-2021-655`
- **State:** Confirmed
- **Severity:** CVSS 2.5 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-131](https://cwe.mitre.org/data/definitions/131.html) · [CWE-193](https://cwe.mitre.org/data/definitions/193.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-193](https://agentprime.io/advisories/tag/cwe-193.md)
- **Published:** 21 May 2021
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 May 2021, 14:22 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `tensorflow` (PyPI): affected `<2.1.4 || >=2.2.0, <2.2.3 || >=2.3.0, <2.3.3 || >=2.4.0, <2.4.2`; fixed in `2.1.4`, `2.2.3`, `2.3.3`, `2.4.2`
- `tensorflow-cpu` (PyPI): affected `<2.1.4 || >=2.2.0, <2.2.3 || >=2.3.0, <2.3.3 || >=2.4.0, <2.4.2`; fixed in `2.1.4`, `2.2.3`, `2.3.3`, `2.4.2`
- `tensorflow-gpu` (PyPI): affected `<2.1.4 || >=2.2.0, <2.2.3 || >=2.3.0, <2.3.3 || >=2.4.0, <2.4.2`; fixed in `2.1.4`, `2.2.3`, `2.3.3`, `2.4.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.5 Low, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0025, the 16th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 21 May 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-jfp7-4j67-8r3q](https://github.com/advisories/GHSA-jfp7-4j67-8r3q)
- [OSV: GHSA-jfp7-4j67-8r3q](https://osv.dev/vulnerability/GHSA-jfp7-4j67-8r3q)
- <https://github.com/tensorflow/tensorflow/security/advisories/GHSA-jfp7-4j67-8r3q>
- <https://nvd.nist.gov/vuln/detail/CVE-2021-29529>
- <https://github.com/tensorflow/tensorflow/commit/f851613f8f0fb0c838d160ced13c134f778e3ce7>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-457.yaml>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-655.yaml>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-166.yaml>
- <https://github.com/tensorflow/tensorflow>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jfp7-4j67-8r3q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jfp7-4j67-8r3q/>. Everything for agents: <https://agentprime.io/llms.txt>.
