# ffuf denial of service (OOM) via HTTP response decompression bomb

Advisory record · `GHSA-jcvh-xf52-2cwm`

- **Identifiers:** `GHSA-jcvh-xf52-2cwm` · `CVE-2026-73232` · `GO-2026-6369`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-409](https://cwe.mitre.org/data/definitions/409.html)
- **Tags:** [CWE-409](https://agentprime.io/advisories/tag/cwe-409.md)
- **Published:** 3 Sept 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Sept 2026, 18:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/ffuf/ffuf/v2` (Go): affected `<2.2.0`; fixed in `2.2.0`
- `github.com/ffuf/ffuf` (Go): affected `<=1.5.0`; no fixed version yet

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> ffuf, the web fuzzing tool, is vulnerable to an out-of-memory denial of service in versions before 2.2.0 (the module github.com/ffuf/ffuf/v2) and in versions up to and including 1.5.0 of github.com/ffuf/ffuf, which has no fixed version listed. A malicious target server can return a small compressed response that expands to a very large body, causing ffuf to exhaust memory and crash, with no special flags needed. Users should upgrade github.com/ffuf/ffuf/v2 to version 2.2.0 or later; for the older module, no fix is listed.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0063, the 50th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:13 UTC: First seen by agentprime
- 31 Oct 2026, 14:13 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jcvh-xf52-2cwm)

## Sources

- [GitHub Advisory Database: GHSA-jcvh-xf52-2cwm](https://github.com/advisories/GHSA-jcvh-xf52-2cwm)
- [OSV: GHSA-jcvh-xf52-2cwm](https://osv.dev/vulnerability/GHSA-jcvh-xf52-2cwm)
- <https://github.com/ffuf/ffuf/security/advisories/GHSA-jcvh-xf52-2cwm>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-73232>
- <https://github.com/ffuf/ffuf/pull/897>
- <https://github.com/ffuf/ffuf/commit/fb0da86c60443b0dddbc9a86e91e3a6487dff79b>
- <https://github.com/ffuf/ffuf>
- <https://github.com/ffuf/ffuf/releases/tag/v2.2.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jcvh-xf52-2cwm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jcvh-xf52-2cwm/>. Everything for agents: <https://agentprime.io/llms.txt>.
