# Moodle Allows Modification of Constants

Advisory record · `GHSA-jcrj-gmr6-p5j8`

- **Identifiers:** `GHSA-jcrj-gmr6-p5j8` · `CVE-2011-4301` · `PKSA-ksnr-kdcy-g89c`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-471](https://cwe.mitre.org/data/definitions/471.html)
- **Tags:** [CWE-471](https://agentprime.io/advisories/tag/cwe-471.md)
- **Published:** 13 May 2022
- **Updated:** 17 Jan 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 May 2022, 01:13 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `moodle/moodle` (Packagist): affected `<1.9.14 || >=2.0, <2.0.5 || >=2.1, <2.1.2`; fixed in `1.9.14`, `2.0.5`, `2.1.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Moodle versions 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 are affected. The MoodleQuickForm class in the Forms Library does not recognize setConstant operations, so a remote attacker can submit altered values for constant form fields and have unexpected content accepted. Upgrade the moodle/moodle package to 1.9.14, 2.0.5, or 2.1.2, depending on the branch in use.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** 0.021, the 81st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:32 UTC: First seen by agentprime
- 31 Oct 2026, 14:32 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-jcrj-gmr6-p5j8)

## Sources

- [GitHub Advisory Database: GHSA-jcrj-gmr6-p5j8](https://github.com/advisories/GHSA-jcrj-gmr6-p5j8)
- [OSV: GHSA-jcrj-gmr6-p5j8](https://osv.dev/vulnerability/GHSA-jcrj-gmr6-p5j8)
- <https://nvd.nist.gov/vuln/detail/CVE-2011-4301>
- <https://github.com/moodle/moodle/commit/1f52e72526c305989eadc702b5299edb2a50ac3c>
- <https://github.com/moodle/moodle/commit/2a44c5192c875c4f4b4e813d7227b19d8fda86ba>
- <https://github.com/moodle/moodle/commit/a6f18c98f43b6fc6b8b7c4e96af41cb4a626e1b8>
- <https://github.com/moodle/moodle/commit/f1f70bd4dde6cd1ea4bdb8ab28fa3d36a53b89d8>
- <https://bugzilla.redhat.com/show_bug.cgi?id=747444>
- <https://github.com/moodle/moodle>
- <http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=f1f70bd4dde6cd1ea4bdb8ab28fa3d36a53b89d8>
- <http://git.moodle.org/gw?p=moodle.git;a=commit;h=f1f70bd4dde6cd1ea4bdb8ab28fa3d36a53b89d8>
- <http://moodle.org/mod/forum/discuss.php?d=188313>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-jcrj-gmr6-p5j8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-jcrj-gmr6-p5j8/>. Everything for agents: <https://agentprime.io/llms.txt>.
