# Moodle authentication bypass vulnerability

Advisory record · `GHSA-j5jv-w5cw-j9ff`

- **Identifiers:** `GHSA-j5jv-w5cw-j9ff` · `BIT-moodle-2025-67848` · `CVE-2025-67848` · `PKSA-d2w7-632f-6wy9`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-280](https://cwe.mitre.org/data/definitions/280.html)
- **Tags:** [CWE-280](https://agentprime.io/advisories/tag/cwe-280.md)
- **Published:** 3 Feb 2026
- **Updated:** 22 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Feb 2026, 12:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `moodle/moodle` (Packagist): affected `<4.1.22 || >=4.4.0-beta, <4.4.12 || >=4.5.0-beta, <4.5.8 || >=5.0.0-beta, <5.0.4 || >=5.1.0-beta, <5.1.1`; fixed in `4.1.22`, `4.4.12`, `4.5.8`, `5.0.4`, `5.1.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Moodle versions before 4.1.22, 4.4.0-beta through before 4.4.12, 4.5.0-beta through before 4.5.8, 5.0.0-beta through before 5.0.4, and 5.1.0-beta through before 5.1.1 are affected. A suspended user can authenticate through the LTI Provider because the LTI authentication handlers do not check suspension status, which can allow information disclosure or other unauthorized actions. Upgrade to 4.1.22, 4.4.12, 4.5.8, 5.0.4, or 5.1.1, depending on your branch. The source gives few details about the exact conditions required for exploitation.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`, from CNA (fedora)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0041, the 35th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:26 UTC: First seen by agentprime
- 31 Oct 2026, 14:26 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-j5jv-w5cw-j9ff)

## Sources

- [GitHub Advisory Database: GHSA-j5jv-w5cw-j9ff](https://github.com/advisories/GHSA-j5jv-w5cw-j9ff)
- [OSV: GHSA-j5jv-w5cw-j9ff](https://osv.dev/vulnerability/GHSA-j5jv-w5cw-j9ff)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-67848>
- <https://github.com/moodle/moodle/commit/62f372e9d861d16df702d3c7726905fa2730e3d8>
- <https://github.com/moodle/moodle/commit/c2705e2c18962fec4f21b9c34ed386be2a379663>
- <https://access.redhat.com/security/cve/CVE-2025-67848>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2423831>
- <https://github.com/moodle/moodle>
- <https://moodle.org/mod/forum/discuss.php?d=471298>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-j5jv-w5cw-j9ff>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-j5jv-w5cw-j9ff/>. Everything for agents: <https://agentprime.io/llms.txt>.
