# httplib2: Decompression Bomb Denial of Service via Unbounded gzip/deflate Response Handling

Advisory record · `GHSA-j5g9-f88f-gfj3`

- **Identifiers:** `GHSA-j5g9-f88f-gfj3` · `CVE-2026-59939` · `PYSEC-2026-3444`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-409](https://cwe.mitre.org/data/definitions/409.html) · [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-409](https://agentprime.io/advisories/tag/cwe-409.md)
- **Published:** 24 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Jul 2026, 15:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `httplib2` (PyPI): affected `<0.32.0`; fixed in `0.32.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> httplib2 versions before 0.32.0 decompress gzip and deflate HTTP response bodies without any size limit. A malicious or compromised server can send a small compressed response that expands to a very large size in memory, causing a MemoryError or an out-of-memory kill in the client process. No authentication or user interaction is needed. Upgrade to httplib2 0.32.0 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0066, the 51st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:35 UTC: First seen by agentprime
- 31 Oct 2026, 14:35 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-j5g9-f88f-gfj3)

## Sources

- [GitHub Advisory Database: GHSA-j5g9-f88f-gfj3](https://github.com/advisories/GHSA-j5g9-f88f-gfj3)
- [OSV: GHSA-j5g9-f88f-gfj3](https://osv.dev/vulnerability/GHSA-j5g9-f88f-gfj3)
- <https://github.com/httplib2/httplib2/security/advisories/GHSA-j5g9-f88f-gfj3>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-59939>
- <https://github.com/httplib2/httplib2/commit/87581ad6cf752fe3da2090c59058261d2d00a427>
- <https://github.com/httplib2/httplib2>
- <https://github.com/httplib2/httplib2/releases/tag/v0.32.0>
- <https://github.com/pypa/advisory-database/tree/main/vulns/httplib2/PYSEC-2026-3444.yaml>
- <https://lists.debian.org/debian-lts-announce/2026/08/msg00039.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-j5g9-f88f-gfj3>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-j5g9-f88f-gfj3/>. Everything for agents: <https://agentprime.io/llms.txt>.
